(Erledigt) Fehler bei Installation

    (Erledigt) Fehler bei Installation

    Hallo,

    ich hoffe ich bin hier im richtigen Forum gelandet, andernfalls bitte ich schon mal vorab um Entschuldigung. :)

    Ich habe folgendes problem auf das ich bisher keine antwort finden konnte..

    Ich besitze einen DigiChat (Version 5.1) im Original.. leider schon etwas länger nicht mehr im Einsatz gewesen und daher auch kein Support mehr seitens des Herstellers ohne das ich gleich wieder für nen Jahr Gebühren an die abdrücken müsste ..

    nun zum problem..

    Auf meinem Linux Root läuft aktuell suse 10.3,
    wenn ich dort nun versuche die Installation des Chat zu starten bricht es nach kurzer zeit ab und gibt mir folgende Fehlermeldung aus:

    /home/digichat # sh ./Install_DigiChat.bin
    Preparing to install...
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...
    awk: cmd. line:6: warning: escape sequence `\.' treated as plain `.'

    Launching installer...

    Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

    Stack Trace:
    java.awt.HeadlessException:
    No X11 DISPLAY variable was set, but this program performed an operation which requires it.
    at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
    at java.awt.Window.<init>(Window.java:407)
    at java.awt.Frame.<init>(Frame.java:402)
    at java.awt.Frame.<init>(Frame.java:367)
    at javax.swing.JFrame.<init>(JFrame.java:163)
    at com.zerog.ia.installer.LifeCycleManager.f(DashoA8113)
    at com.zerog.ia.installer.LifeCycleManager.g(DashoA8113)
    at com.zerog.ia.installer.LifeCycleManager.a(DashoA8113)
    at com.zerog.ia.installer.Main.main(DashoA8113)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at com.zerog.lax.LAX.launch(DashoA8113)
    at com.zerog.lax.LAX.main(DashoA8113)
    This Application has Unexpectedly Quit: Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

    weiter geht es nicht.. hat jemand von euch evtl eine Idee wodran es liegen könnte ?

    Gruß
    Poldi

    AW: Fehler bei Installation

    Poldi1977 schrieb:


    Ich besitze einen DigiChat (Version 5.1) im Original.. leider schon etwas länger nicht mehr im Einsatz gewesen und daher auch kein Support mehr seitens des Herstellers ohne das ich gleich wieder für nen Jahr Gebühren an die abdrücken müsste ..


    Unsupportete Software auf einem

    Poldi1977 schrieb:

    Linux Root


    zu betreiben, sollte man unterlassen.


    Vor allem, wenn diese scheinbar

    Quellcode

    1. Stack Trace:
    2. java.awt.HeadlessException:
    3. [B]No X11 DISPLAY variable was set, but this program performed an operation which requires it.[/B]


    X benötigt, was auf einem Linux-Root überhaupt nichts zu suchen hat.

    Und weil das Ding wahrscheinlich

    a) proprietär

    b) älter

    ist, wird es auch wahrscheinlich auf einer aktuelleren Distribution gar nicht laufen.

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.19.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K

    AW: Fehler bei Installation

    Hi, erstmal Danke für Deine antwort..

    bin einen kleinen schritt weiter gekommen...

    als ich die Installation mit folgendem Befehl ausgeführt habe:

    sh ./Install_DigiChat.bin -i console

    funktionierte sie, ich konnte /musste nun einige angaben machen und die Installation wurde nun scheinbar erfolgreich abgeschlossen...
    Als ich aber nun den chat-server starten wollte mit dem Befehl:

    ./DC_Server erhielt ich wieder nen Fehler..

    awk: error while loading shared libraries: libdl.so.2: cannot open shared object file: No such file or directory
    dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    /bin/ls: error while loading shared libraries: librt.so.1: cannot open shared object file: No such file or directory
    basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    dirname: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    basename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    grep: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory
    /bin/bash: error while loading shared libraries: libdl.so.2: cannot open shared object file: No such file or directory

    :eek:

    AW: Fehler bei Installation

    Wende Dich an den Support, das Ding ist nach allem, was man da sieht, zur jetzigen Version des OS inkompatibel, wenn es nicht einmal diese grundlegenden Systembibliotheken findet.

    Mal ganz davon abgesehen, daß mir diese Sache auch aus lizenzrechtlichen Gründen nicht koscher vorkommt.

    Sofern keine gültige Lizenz vorliegt, ist das Betreiben der Software nicht legal und hierzu wird es so oder so keine Tipps geben.

    Von fehlenden Sicherheits-/Kompatibilitätsupdates mal ganz abgesehen.

    Der Hersteller ist der einzige, der Dir eine kompatible und rechtlich einwandfreie Version bieten kann.

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.19.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K