(Gelöst) Ralink rt2860 unter openSUSE 11.0/11.1 (EEEPC und andere EEE-Hardware)

    AW: Ralink rt2860 unter openSUSE 11.1

    Könnte dieses Jahr natürlich wirklich knapp werden, aber ich lade es mal trotzdem hoch.

    Da die 1.7.1.1er funktionieren besteht ja auch kein Grund zur Eile.

    Siehe Anhang.

    //Edit Anhang gelöscht, siehe letzten Beitrag dieses Threads

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.17.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Rain_Maker“ ()

    AW: Ralink rt2860 unter openSUSE 11.1

    Rain_Maker schrieb:


    Ich hätte da noch etwas zum Ausprobieren, ein gepatchtes Paket Version 1.8.0.0, ich habe aber keine Ahnung, ob die Verbindung damit klappt.


    Nein, diese Version funktioniert auf meiner Eee-Box 202 nicht. Es ist wie üblich: der Treiber wird korrekt geladen und das Interface ist mit ifconfig sichtbar:

    Quellcode

    1. wlan0 Link encap:Ethernet Hardware Adresse 00:15:AF:DB:8E:30
    2. UP BROADCAST MULTICAST MTU:1500 Metric:1
    3. RX packets:5815 errors:0 dropped:0 overruns:0 frame:0
    4. TX packets:2428 errors:0 dropped:0 overruns:0 carrier:0
    5. collisions:0 Sendewarteschlangenlänge:1000
    6. RX bytes:835549 (815.9 Kb) TX bytes:0 (0.0 b)
    7. Interrupt:17


    Man beachte: keine IP-Adresse (das Interface ist auf DHCP konfiguriert), aber jede Menge gesendeter und empfangener Pakete. Die Anzahl der gesendeten Bytes ist aber Null!
    Das Scannen des Netzwerkes funktioniert auch:

    Quellcode

    1. iwlist wlan0 scanning
    2. wlan0 Scan completed :
    3. Cell 01 - Address: 00:1C:4A:43:21:5A
    4. ESSID:"AKIRANET"
    5. Mode:Managed
    6. Channel:1
    7. Quality:100/100 Signal level:-40 dBm Noise level:-97 dBm
    8. Encryption key:on
    9. Bit Rates:11 Mb/s
    10. IE: WPA Version 1
    11. Group Cipher : TKIP
    12. Pairwise Ciphers (1) : TKIP
    13. Authentication Suites (1) : PSK
    14. IE: IEEE 802.11i/WPA2 Version 1
    15. Group Cipher : TKIP
    16. Pairwise Ciphers (1) : CCMP
    17. Authentication Suites (1) : PSK


    Aber es besteht effektiv keine Verbindung. Ohne die Änderungen aus der Version 1.7.1.1 geht es also zumindest auf meinem Gerät nicht.
    Meine (wilde) Theorie: Der Sender ist nicht eingeschaltet, denn im Protokoll meines Routers (leider ziemlich dürftig) wird nichts über fehlgeschlagene Verbindungsversuche berichtet. Hat jemand eine Idee, wie man prüfen könnte, ob der Sender strahlt oder nicht?
    Für die Treiber-Entwicklung wäre es nun natürlich einmal interessant, heraus zu finden, welche Geräte unter welcher Konstellation der Treiber funktionieren. Sind die Geräte anhand der PCI-ID unterscheidbar oder gibt es irgendein anderes Kriterium?

    lspci -v liefert bei mir (unter openSUSE 11.0)

    Quellcode

    1. 03:00.0 Network controller: RaLink Device 0781
    2. Subsystem: RaLink Device 2790
    3. Flags: bus master, fast devsel, latency 0, IRQ 17
    4. Memory at fe7f0000 (32-bit, non-prefetchable) [size=64K]
    5. Capabilities: [40] Power Management version 3
    6. Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/5 Enable-
    7. Capabilities: [70] Express Endpoint, MSI 00
    8. Kernel driver in use: rt2860
    9. Kernel modules: rt2860sta


    Euch allen ein frohes neues Jahr!
    Jürgen

    AW: Ralink rt2860 unter openSUSE 11.1

    OK, dann bringen wir den Thread hier zu seinem wohlverdienten Ende.

    //Edit (RM):

    Downloadlinks gelöscht, siehe auch:


    pc-forum24.de/ankuendigungen-w…dsektion-geschlossen.html

    c) Wer zuvor mit sebstgebauten Treibern oder mit Treiber-RPMs aus anderen Quellen experimentiert hatte, der sollte vor der Installation der obigen Pakete folgende Schritte durchführen.

    - Das Modul der von Hand installierten Treiber löschen (nach Dateien mit dem Dateinamen "rt2860sta.ko" in /lib/modules/<Kernelversion> suchen) bzw. entsprechendes RPM-Paket deinstallieren

    - eine eventuell vorhandenen Datei /etc/sysconfig/network/ifcfg-ra0 entweder löschen oder in "ifcfg-wlan0" umbenennen

    - Die Datei /etc/udev/rules.d/70-persistent-net.rules löschen oder den Eintrag zur WLAN-Karte mit einem Editor als root von "ra0" in "wlan0" ändern.

    - Danach das entsprechende RPM-Paket installieren und als root

    Quellcode

    1. udevadm trigger
    durchführen bzw. die Kiste neu starten, damit die udev-Regeln neu geschrieben werden.

    d) Den Titel habe ich noch um ein paar Stichworte (EEE und openSUSE Versionen) erweitert, damit er besser per Suchmaschine gefunden wird.

    jinxy schrieb:

    Euch allen ein frohes neues Jahr!


    Dito, und nochmal Danke fürs Testen.

    => Licht aus.

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.17.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „Rain_Maker“ ()