(Gelöst) WLAN mit ifup in OpenSuse 11.1 einrichten (rt73 legacy Treiber)

    (Gelöst) WLAN mit ifup in OpenSuse 11.1 einrichten (rt73 legacy Treiber)

    Hallo,

    habe gerade von 10.3 zu 11.1 gewechselt und kaempfe seit zwei Tagen mit WLAN. Unter 10.3 ging es, nachdem ich die Anleitung in
    pc-forum24.de/linux-howtos/856…nsuse-10-x.html#post23252
    gefolgt hatte. Ich hab's erst mal mit den eingebauten Treiber versucht und es hat nicht funktioniert, also habe ich wieder mit ifup wie unter 10.3 probiert aber komme nicht weiter.

    Derzeit sieht es so aus:

    Quellcode

    1. # uname -r
    2. 2.6.27.21-0.1-pae


    Quellcode

    1. # cat /etc/SuSE-release
    2. openSUSE 11.1 (i586)
    3. VERSION = 11.1


    Quellcode

    1. # lsusb
    2. Bus 004 Device 002: ID 03f0:1204 Hewlett-Packard DeskJet 930c
    3. Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    4. Bus 002 Device 002: ID 04b8:011d Seiko Epson Corp. Perfection 1260 Photo
    5. Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    6. Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    7. Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    8. Bus 001 Device 005: ID 05e3:070b Genesys Logic, Inc. DMHS1B Rev 3 DFU Adapter
    9. Bus 001 Device 003: ID 07d1:3c03 D-Link System DWL-G122 802.11g Adapter [ralink rt73]
    10. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Quellcode

    1. # ls -l /lib/firmware
    2. total 48
    3. drwxr-xr-x 14 root root 4096 2009-04-18 13:19 2.6.27.21-0.1-pae
    4. -rw-r--r-- 1 root root 2142 2009-03-16 07:34 LICENSE.ralink-firmware.txt
    5. -rw-r--r-- 1 root root 8192 2009-03-16 07:34 rt2561.bin
    6. -rw-r--r-- 1 root root 8192 2009-03-16 07:34 rt2561s.bin
    7. -rw-r--r-- 1 root root 8192 2009-03-16 07:34 rt2661.bin
    8. -rw-r--r-- 1 root root 8192 2009-03-16 07:34 rt2860.bin
    9. -rw-r--r-- 1 root root 4096 2009-03-16 07:34 rt2870.bin
    10. -rw-r--r-- 1 root root 2048 2009-03-16 07:34 rt73.bin


    Quellcode

    1. # dmesg|grep -i firmware
    2. intel_rng: Firmware space is locked read-only. If you can't or
    3. intel_rng: don't want to disable this in firmware setup, and if
    4. firmware: requesting rt73.bin
    5. firmware: requesting intel-ucode/0f-02-09
    6. firmware: requesting intel-ucode/0f-02-09


    Quellcode

    1. # /usr/sbin/rcsmpppd status
    2. Checking for SMPPPD: running


    Quellcode

    1. # rpm -qa|egrep 'rt73|wpa'
    2. rt73-cvs-kmp-pae-2009030304_2.6.27.21_0.1-13.1
    3. wpa_supplicant-0.6.9-1.2


    Quellcode

    1. # hwinfo --wlan
    2. 18: USB 00.0: 0282 WLAN controller
    3. [Created at usb.122]
    4. UDI: /org/freedesktop/Hal/devices/usb_device_7d1_3c03_noserial_if0
    5. Unique ID: wkjR.Pj1JuB68U+F
    6. Parent ID: k4bc.9T1GDCLyFd9
    7. SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0
    8. SysFS BusID: 1-5:1.0
    9. Hardware Class: network
    10. Model: "D-Link 802.11 bg WLAN"
    11. Hotplug: USB
    12. Vendor: usb 0x07d1 "D-Link System"
    13. Device: usb 0x3c03 "802.11 bg WLAN"
    14. Revision: "0.01"
    15. Driver: "rt73"
    16. Driver Modules: "rt73"
    17. Device File: wlan0
    18. Features: WLAN
    19. Speed: 480 Mbps
    20. HW Address: 00:21:91:55:7b:e9
    21. Link detected: yes
    22. WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
    23. WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
    24. WLAN bitrates: 1 2 5.5 11 9 18 36 54
    25. WLAN encryption modes: WEP40 WEP104
    26. WLAN authentication modes: open sharedkey
    27. Module Alias: "usb:v07D1p3C03d0001dc00dsc00dp00icFFiscFFipFF"
    28. Driver Info #0:
    29. Driver Status: rt73 is active
    30. Driver Activation Cmd: "modprobe rt73"
    31. Driver Info #1:
    32. Driver Status: rt73usb is not active
    33. Driver Activation Cmd: "modprobe rt73usb"
    34. Config Status: cfg=no, avail=yes, need=no, active=unknown
    35. Attached to: #15 (Hub)


    Dies habe ich aus einem 10.3 Laptop (Karte laeuft gut drauf) in das 11.1 System kopiert. Der Grund: YAST hat nur WEP als Verschluesselung angeboten. Ich bekommen keine Fehlermeldungen, aber bei hwinfo sehe ich ja nur WEP... vielleicht ist dies mein Problem? YAST bietet jetzt aber auch WPA-PSK.

    Quellcode

    1. BOOTPROTO='dhcp'
    2. BROADCAST=''
    3. ETHTOOL_OPTIONS=''
    4. IFPLUGD_PRIORITY='10'
    5. IPADDR=''
    6. MTU=''
    7. NAME=''
    8. NETMASK=''
    9. NETWORK=''
    10. REMOTE_IPADDR=''
    11. STARTMODE='ifplugd'
    12. USERCONTROL='yes'
    13. WIRELESS_AP=''
    14. WIRELESS_AUTH_MODE='psk'
    15. WIRELESS_BITRATE='auto'
    16. WIRELESS_CA_CERT=''
    17. WIRELESS_CHANNEL=''
    18. WIRELESS_CLIENT_CERT=''
    19. WIRELESS_CLIENT_KEY=''
    20. WIRELESS_CLIENT_KEY_PASSWORD=''
    21. WIRELESS_DEFAULT_KEY='0'
    22. WIRELESS_EAP_AUTH=''
    23. WIRELESS_EAP_MODE=''
    24. WIRELESS_ESSID='My-WLAN'
    25. WIRELESS_FREQUENCY=''
    26. WIRELESS_KEY=''
    27. WIRELESS_KEY_0=''
    28. WIRELESS_KEY_1=''
    29. WIRELESS_KEY_2=''
    30. WIRELESS_KEY_3=''
    31. WIRELESS_KEY_LENGTH='128'
    32. WIRELESS_MODE='Managed'
    33. WIRELESS_NICK=''
    34. WIRELESS_NWID=''
    35. WIRELESS_PEAP_VERSION=''
    36. WIRELESS_POWER='yes'
    37. WIRELESS_WPA_ANONID=''
    38. WIRELESS_WPA_IDENTITY=''
    39. WIRELESS_WPA_PASSWORD=''
    40. WIRELESS_WPA_PSK='psswrd'


    Quellcode

    1. # iwconfig
    2. lo no wireless extensions.
    3. wlan0 RT73 WLAN ESSID:"" Nickname:"linux-1prh"
    4. Mode:Managed Frequency=2.472 GHz Bit Rate=54 Mb/s
    5. RTS thr:off Fragment thr:off
    6. Encryption key:off
    7. Link Quality=77/100 Signal level:-62 dBm Noise level:-115 dBm
    8. Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    9. Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    10. eth0 no wireless extensions.
    11. eth1 no wireless extensions.


    Nach ifdown wlan0 und ifup wlan0 sieht es so aus:

    Brainfuck-Quellcode

    1. # sudo tail -f /var/log/messages
    2. Apr 18 16:32:39 linux-1prh ifdown: wlan0
    3. Apr 18 16:32:39 linux-1prh dhcpcd[19966]: wlan0: received SIGTERM, stopping
    4. Apr 18 16:32:39 linux-1prh dhcpcd[19966]: wlan0: removing IP address 192.168.2.103/24
    5. Apr 18 16:32:39 linux-1prh avahi-daemon[3702]: Withdrawing address record for 192.168.2.103 on wlan0.
    6. Apr 18 16:32:39 linux-1prh avahi-daemon[3702]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.103.
    7. Apr 18 16:32:39 linux-1prh avahi-daemon[3702]: Interface wlan0.IPv4 no longer relevant for mDNS.
    8. Apr 18 16:32:39 linux-1prh dhcpcd[19966]: wlan0: exiting
    9. Apr 18 16:32:40 linux-1prh avahi-daemon[3702]: Withdrawing address record for fe80::221:91ff:fe55:7be9 on wlan0.
    10. Apr 18 16:32:40 linux-1prh kernel: rt73: closed
    11. Apr 18 16:32:43 linux-1prh ifup: wlan0
    12. Apr 18 16:32:43 linux-1prh ifup: wlan0 is controlled by ifplugd
    13. Apr 18 16:32:43 linux-1prh ifup: wlan0
    14. Apr 18 16:32:43 linux-1prh ifup-wireless: wlan0 starting wpa_supplicant
    15. Apr 18 16:32:43 linux-1prh kernel: rt73: driver version - 1.0.3.6 CVS
    16. Apr 18 16:32:43 linux-1prh kernel: rt73: using net dev supplied MAC addr
    17. Apr 18 16:32:43 linux-1prh kernel: rt73: Active MAC addr: 00:21:91:55:7b:e9
    18. Apr 18 16:32:43 linux-1prh kernel: rt73: Local MAC = 00:21:91:55:7b:e9
    19. Apr 18 16:32:44 linux-1prh ifup-dhcp: Starting DHCP4 client on wlan0
    20. Apr 18 16:32:44 linux-1prh dhcpcd[20800]: wlan0: dhcpcd 3.2.3 starting
    21. Apr 18 16:32:44 linux-1prh dhcpcd[20800]: wlan0: hardware address = 00:21:91:55:7b:e9
    22. Apr 18 16:32:44 linux-1prh dhcpcd[20800]: wlan0: broadcasting for a lease
    23. Apr 18 16:32:45 linux-1prh ifup-dhcp: .
    24. Apr 18 16:32:45 linux-1prh avahi-daemon[3702]: Registering new address record for fe80::221:91ff:fe55:7be9 on wlan0.*.
    25. Apr 18 16:32:47 linux-1prh ifup-dhcp: .
    26. Apr 18 16:32:49 linux-1prh ifup-dhcp: .
    27. Apr 18 16:32:51 linux-1prh ifup-dhcp: .
    28. Apr 18 16:32:53 linux-1prh ifup-dhcp: .
    29. Apr 18 16:32:54 linux-1prh kernel: wlan0: no IPv6 routers present
    30. Apr 18 16:32:55 linux-1prh ifup-dhcp: .
    31. Apr 18 16:32:57 linux-1prh ifup-dhcp: .
    32. Apr 18 16:32:59 linux-1prh ifup-dhcp: .
    33. Apr 18 16:33:01 linux-1prh ifup-dhcp:
    34. Apr 18 16:33:01 linux-1prh ifup-dhcp: wlan0 DHCP4 continues in background
    35. Apr 18 16:33:04 linux-1prh dhcpcd[20800]: wlan0: timed out
    36. Apr 18 16:33:04 linux-1prh dhcpcd[20800]: wlan0: trying to use old lease in `/var/lib/dhcpcd/dhcpcd-wlan0.info'
    37. Apr 18 16:33:04 linux-1prh dhcpcd[20800]: wlan0: adding IP address 192.168.2.103/24
    38. Apr 18 16:33:04 linux-1prh avahi-daemon[3702]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.2.103.
    39. Apr 18 16:33:04 linux-1prh avahi-daemon[3702]: New relevant interface wlan0.IPv4 for mDNS.
    40. Apr 18 16:33:04 linux-1prh avahi-daemon[3702]: Registering new address record for 192.168.2.103 on wlan0.IPv4.
    41. Apr 18 16:33:04 linux-1prh dhcpcd[20800]: wlan0: adding default route via 192.168.2.1 metric 0
    42. Apr 18 16:33:04 linux-1prh syslog-ng[2147]: Configuration reload request received, reloading configuration;
    43. Apr 18 16:33:04 linux-1prh syslog-ng[2147]: New configuration initialized;
    44. Apr 18 16:33:04 linux-1prh kernel: klogd 1.4.1, ---------- state change ----------
    45. Apr 18 16:33:04 linux-1prh ifdown: wlan0
    46. Apr 18 16:33:04 linux-1prh ifup: wlan0
    47. Apr 18 16:33:05 linux-1prh SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    48. Apr 18 16:33:05 linux-1prh SuSEfirewall2: using default zone 'ext' for interface eth0
    49. Apr 18 16:33:05 linux-1prh SuSEfirewall2: batch committing...
    50. Apr 18 16:33:05 linux-1prh SuSEfirewall2: Firewall rules successfully set
    51. Apr 18 16:33:05 linux-1prh dhcpcd[20800]: wlan0: exiting


    Die LED leuchten kurz auf und dann ist alles wieder finster.


    Quellcode

    1. # ping -c5 192.68.2.103
    2. PING 192.68.2.103 (192.68.2.103) 56(84) bytes of data.
    3. --- 192.68.2.103 ping statistics ---
    4. 5 packets transmitted, 0 received, 100% packet loss, time 4012ms


    Quellcode

    1. # iwlist scan
    2. lo Interface doesn't support scanning.
    3. wlan0 No scan results
    4. eth0 Interface doesn't support scanning.
    5. eth1 Interface doesn't support scanning.



    Vielleicht hat ja jemand Zeit und Lust, mir aus der Klemme zu helfen. :confused: Ich komme einfach nicht weiter.

    Danke schoen!

    Wasserman

    AW: WLAN mit ifup in OpenSuse 11.1 einrichten (rt73 legacy Treiber)

    das Problem hat sich inszwischen geloest. Es hatte nicht unbedingt mit dem Treiber/Frimware zu tun, sonder mit meinem WLAN Router. Ich hatte es bisher mit einem Speedport W700 V versucht. Ich habe mich aber wieder daran erinnert, dass die Konfiguration mit NetworkManager auf meinem Laptop mit manchen Router geklappt hat und bei anderen nicht. Also habe ich den DSL Router gewechselt zu einem Speedport W 503V. Hier klappt's mit der NetworkManager-Methode.

    Schoenes WE.