Soundproblem suse 11.1

      Soundproblem suse 11.1

      Hallo Leute.

      Bin ein Linux anfänger, und hab gleich mal ein riesen Problem.

      Ich bekomme meine Soundkarte einfach nicht zum laufen.
      Wenn Linux startet, kommt ein Hinweis, dass der Audioadapter nicht richtig funktioniert und auf "default" gesetzt wurde.

      Hab schon alles mögliche versucht, und z.B. die ALSA Treiber neu installiert.

      Hier die Ausgabe von "hwinfo"

      Quellcode

      1. 15: PCI 1b.0: 0403 Audio device
      2. [Created at pci.318]
      3. UDI: /org/freedesktop/Hal/devices/pci_8086_27d8
      4. Unique ID: u1Nb.tgJ37CWH+y6
      5. SysFS ID: /devices/pci0000:00/0000:00:1b.0
      6. SysFS BusID: 0000:00:1b.0
      7. Hardware Class: sound
      8. Model: "Intel 82801G (ICH7 Family) High Definition Audio Controller"
      9. Vendor: pci 0x8086 "Intel Corporation"
      10. Device: pci 0x27d8 "82801G (ICH7 Family) High Definition Audio Controller"
      11. SubVendor: pci 0x103c "Hewlett-Packard Company"
      12. SubDevice: pci 0x3012
      13. Revision: 0x01
      14. Driver: "HDA Intel"
      15. Driver Modules: "snd_hda_intel"
      16. Memory Range: 0xe04c0000-0xe04c3fff (rw,non-prefetchable)
      17. IRQ: 21 (286 events)
      18. Module Alias: "pci:v00008086d000027D8sv0000103Csd00003012bc04sc03i00"
      19. Driver Info #0:
      20. Driver Status: snd_hda_intel is active
      21. Driver Activation Cmd: "modprobe snd_hda_intel"
      22. Config Status: cfg=no, avail=yes, need=no, active=unknown

      Wäre super, wenn mir jemand helfen könnte!

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „spidy“ ()

      AW: Soundproblem suse 11.1

      Hast Du schon "alsaconf" probiert ?

      Konsole aufmachen und ....

      Quellcode

      1. su
      2. [Dein Password für root]
      3. alsaconf
      Den Anweisungen folgen & am Ende sollte ein Test-Sound zu hören sein.
      [SIGPIC][/SIGPIC]

      Helfe Dir selbst, sonst hilft Dir keiner, gut, dass es nicht immer stimmt ! ;-)

      Never argue with an idíot, they drag you down to their level and beat you with experience !

      Non scholae, sed vitae, discimus !

      AW: Soundproblem suse 11.1

      SDB:Intel-hda - openSUSE

      Anmerkung:

      Für die dort erwähnte Dokumentationsdatei muss das Paket "kernel-source" installiert sein.
      "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

      Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

      openSUSE Leap 42.3 - Kernel 4.14.x - fluxbox 1.3.7

      Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K

      AW: Soundproblem suse 11.1

      Hallo chris1981,

      da

      Quellcode

      1. SubVendor: pci 0x103c "[B]Hewlett-Packard[/B] Company"

      vermute ich an, dass du einen HP besitzt. Dann müsstest "hp" hinzufügen, falls dein Modul ALC260 ist. Es sei denn, du hast die 3013-Variante, dann "hp-3013", oder wenn du einen HP DC7600 besitzt, dann "hp-dc7600".
      So genau können wir dir das aber nicht sagen. Gut wäre, wenn du ein paar mehr Informationen posten könntest, damit wir nicht raten müssen, sondern wirklich helfen können.

      Z.B. könntest du auch die einzelnen Befehle des verlinkten Lösungsvorschlages posten.

      Schöne Grüße,
      benne
      Jabber:
      benne_@jabber.ccc.de

      Der pc-forum24.de Chat:
      #pc-forum24.de im QuakeNet!
      pc-forum24.de@conference.jabber.ccc.de

      AW: Soundproblem suse 11.1

      Also, der passende Eintrag in der ALSA-Configuration.txt lautet so:


      ALC260
      hp HP machines
      hp-3013 HP machines (3013-variant)
      hp-dc7600 HP DC7600
      fujitsu Fujitsu S7020
      acer Acer TravelMate
      will Will laptops (PB V7900)
      replacer Replacer 672V
      basic fixed pin assignment (old default model)
      test for testing/debugging purpose, almost all controls can
      adjusted. Appearing only when compiled with
      $CONFIG_SND_DEBUG=y
      auto auto-config reading BIOS (default)



      In der Config-Datei von ALSA steht bei mir aber nur:

      alias snd-card-0 snd-hda-intel
      alias sound-slot-0 snd-hda-intel



      Was muss ich in die Datei "Sound" eintragen?

      Hier nochmal der aktuelle Auszug aus der "HWINFO"


      15: PCI 1b.0: 0403 Audio device
      [Created at pci.318]
      UDI: /org/freedesktop/Hal/devices/pci_8086_27d8
      Unique ID: u1Nb.tgJ37CWH+y6
      SysFS ID: /devices/pci0000:00/0000:00:1b.0
      SysFS BusID: 0000:00:1b.0
      Hardware Class: sound
      Model: "Intel 82801G (ICH7 Family) High Definition Audio Controller"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x27d8 "82801G (ICH7 Family) High Definition Audio Controller"
      SubVendor: pci 0x103c "Hewlett-Packard Company"
      SubDevice: pci 0x3012
      Revision: 0x01
      Driver: "HDA Intel"
      Driver Modules: "snd_hda_intel"
      Memory Range: 0xe04c0000-0xe04c3fff (rw,non-prefetchable)
      IRQ: 21 (3178 events)
      Module Alias: "pci:v00008086d000027D8sv0000103Csd00003012bc04sc03i00"
      Driver Info #0:
      Driver Status: snd_hda_intel is active
      Driver Activation Cmd: "modprobe snd_hda_intel"
      Config Status: cfg=no, avail=yes, need=no, active=unknown


      Ich habe einen Desktop PC von HP. Model dc7600


      Also ich bin kurz davor wieder Windows zu installieren :(

      AW: Soundproblem suse 11.1

      Eigentlich steht es in der Anleitung sehr gut beschrieben drin, was man ausprobieren muss.

      Datei vor der Änderung (Beispiel):

      Quellcode

      1. options snd-hda-intel enable=1 index=0
      2. # u1Nb.jN8_s9AC_37:82801H (ICH8 Family) HD Audio Controller
      3. alias snd-card-0 snd-hda-intel

      Datei nach der Änderung:

      Quellcode

      1. options snd-hda-intel [B]model=6stack-dig[/B] enable=1 index=0
      2. # u1Nb.jN8_s9AC_37:82801H (ICH8 Family) HD Audio Controller
      3. alias snd-card-0 snd-hda-intel


      Das wäre also ein Beispiel, bei Dir gibt es folgende Modelle zum Codec.

      Quellcode

      1. ALC260
      2. [B]hp[/B] HP machines
      3. [B]hp-3013[/B] HP machines (3013-variant)
      4. [B]hp-dc7600[/B] HP DC7600
      5. [B]fujitsu[/B] Fujitsu S7020
      6. [B]acer[/B] Acer TravelMate
      7. [B]will[/B] Will laptops (PB V7900)
      8. [B]replacer[/B] Replacer 672V
      9. [B]basic[/B] fixed pin assignment (old default model)


      Ich habe einen Desktop PC von HP. Model dc7600


      Dann ist eigentlich klar, was man als erstes ausprobieren sollte.
      "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

      Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

      openSUSE Leap 42.3 - Kernel 4.14.x - fluxbox 1.3.7

      Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K

      AW: Soundproblem suse 11.1

      Wenn die Zeile mit "options" fehlt, dann natürlich die gesamte Zeile hinzufügen.
      "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

      Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

      openSUSE Leap 42.3 - Kernel 4.14.x - fluxbox 1.3.7

      Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K