openSUSE Leap: Wo kann ich mein DSL einrichten?

      openSUSE Leap: Wo kann ich mein DSL einrichten?

      Unter Network Devices / DSL konnte ich unter Suse immer eine PPPOE Verbindung konfigurieren,
      leider finde ich im neuen Leap unter Yast keine Möglichkeit!


      Ich habe eine reine Test-Installation ohne Grafik.

      Nachtrag: 1 Stunde um Netz gesucht und nichts gefunden
      Apache startet leider auch nicht.
      Ich werde es wohl erst mal mit suse13.2 versuchen
      Nachtrag2:
      Bin wieder bei Suse13.1.
      /var/log/messes jetzt vor anders
      Kein DSL
      Apche startet nicht,
      @Suse
      Ich habe ja nichts gegen neue Funktion, aber wenn man mal schnell einen Server aufsetzen must hat man keine Zeit alles neu zu lernen und im Internet nach Lösungen zu suchen!




      Nachtrag 2: Man benötigt den Network Manager, der aber sowas wie kde voraus setzt, also
      Textmodus keine Change.
      Das wurde ab 13.2 eingeführt.


      Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „amiga1200“ ()

      Dann mal der Reihe nach:

      1) Ja, seit 13.2 ist der Punkt zum Einrichten von PPP-Verbindungen (DSL oder "normale" Modemverbindungen) nicht mehr in "yast2-network" vorhanden (IIRC kein Maintainer mehr).

      2) Nein, man benötigt keinen NetworkManager für DSL, wer es gerne ganz "puristisch" hat, braucht nicht mal irgendein extra-Paket außer pppd und schreibt sich die Konfigurationen für Einwahlverbindungen selbst. Wer es gerne etwas bequemer haben will:

      Quellcode

      1. rpm -qpil rp-pppoe-3.11-5.1.x86_64.rpm
      2. Name : rp-pppoe
      3. Version : 3.11
      4. Release : 5.1
      5. Architecture: x86_64
      6. Install Date: (not installed)
      7. Group : Productivity/Networking/PPP
      8. Size : 408663
      9. License : GPL-2.0+
      10. Signature : RSA/SHA256, Mi 30 Sep 2015 12:55:45 CEST, Key ID b88b2fd43dbdc284
      11. Source RPM : rp-pppoe-3.11-5.1.src.rpm
      12. Build Date : Mi 30 Sep 2015 12:55:38 CEST
      13. Build Host : build76
      14. Relocations : (not relocatable)
      15. Packager : http://bugs.opensuse.org
      16. Vendor : openSUSE
      17. URL : http://www.roaringpenguin.com/pppoe
      18. Summary : A PPP Over Ethernet Redirector for PPPD
      19. Description :
      20. rp-pppoe is a user-space redirector which permits the use of PPPoE
      21. (Point-to-Point Protocol Over Ethernet) with Linux. PPPoE is used by
      22. many ADSL service providers.
      23. Authors:
      24. --------
      25. David F. Skoll <http://www.roaringpenguin.com>
      26. Distribution: openSUSE Leap 42.1
      27. /etc/init.d/pppoe
      28. /etc/ppp/firewall-masq
      29. /etc/ppp/firewall-standalone
      30. /etc/ppp/pppoe-server-options
      31. /etc/ppp/pppoe.conf
      32. /etc/ppp/rp-pppoe-gui
      33. /usr/bin/tkpppoe
      34. /usr/sbin/pppoe
      35. /usr/sbin/pppoe-connect
      36. /usr/sbin/pppoe-relay
      37. /usr/sbin/pppoe-server
      38. /usr/sbin/pppoe-setup
      39. /usr/sbin/pppoe-sniff
      40. /usr/sbin/pppoe-start
      41. /usr/sbin/pppoe-status
      42. /usr/sbin/pppoe-stop
      43. /usr/sbin/pppoe-wrapper
      44. /usr/sbin/rcpppoe
      45. /usr/share/doc/packages/rp-pppoe
      46. /usr/share/doc/packages/rp-pppoe/CHANGES
      47. /usr/share/doc/packages/rp-pppoe/HOW-TO-CONNECT
      48. /usr/share/doc/packages/rp-pppoe/KERNEL-MODE-PPPOE
      49. /usr/share/doc/packages/rp-pppoe/LICENSE
      50. /usr/share/doc/packages/rp-pppoe/README
      51. /usr/share/doc/packages/rp-pppoe/README.plugins
      52. /usr/share/doc/packages/rp-pppoe/SERVPOET
      53. /usr/share/doc/packages/rp-pppoe/pap-secrets
      54. /usr/share/man/man1/pppoe-wrapper.1.gz
      55. /usr/share/man/man1/tkpppoe.1.gz
      56. /usr/share/man/man5/pppoe.conf.5.gz
      57. /usr/share/man/man8/pppoe-connect.8.gz
      58. /usr/share/man/man8/pppoe-relay.8.gz
      59. /usr/share/man/man8/pppoe-server.8.gz
      60. /usr/share/man/man8/pppoe-setup.8.gz
      61. /usr/share/man/man8/pppoe-sniff.8.gz
      62. /usr/share/man/man8/pppoe-start.8.gz
      63. /usr/share/man/man8/pppoe-status.8.gz
      64. /usr/share/man/man8/pppoe-stop.8.gz
      65. /usr/share/man/man8/pppoe.8.gz
      66. /usr/share/tkpppoe
      67. /usr/share/tkpppoe/en.msg
      68. /usr/share/tkpppoe/ja.msg
      69. /usr/share/tkpppoe/mainwin-busy.png
      70. /usr/share/tkpppoe/mainwin-nonroot.png
      71. /usr/share/tkpppoe/mainwin.png
      72. /usr/share/tkpppoe/props-advanced.png
      73. /usr/share/tkpppoe/props-basic.png
      74. /usr/share/tkpppoe/props-nic.png
      75. /usr/share/tkpppoe/props-options.png
      76. /usr/share/tkpppoe/tkpppoe.html


      3) Und dann wäre da noch eine Ergänzung:

      tomfa schrieb:


      Sehe ich anders und lief hier auch schon im Textmodus.


      ACK, NetworkManager hat per se _keine_ Abhängigkeiten zu _irgendeiner_ grafischen Oberfläche.

      Quellcode

      1. rpm -qp --requires NetworkManager-1.0.6-1.2.x86_64.rpm
      2. /bin/sh
      3. /bin/sh
      4. /bin/sh
      5. /bin/sh
      6. /bin/sh
      7. config(NetworkManager) = 1.0.6-1.2
      8. dhcp-client
      9. iproute2
      10. iputils
      11. libbluetooth.so.3()(64bit)
      12. libc.so.6()(64bit)
      13. libc.so.6(GLIBC_2.14)(64bit)
      14. libc.so.6(GLIBC_2.17)(64bit)
      15. libc.so.6(GLIBC_2.2.5)(64bit)
      16. libc.so.6(GLIBC_2.3)(64bit)
      17. libc.so.6(GLIBC_2.3.4)(64bit)
      18. libc.so.6(GLIBC_2.4)(64bit)
      19. libc.so.6(GLIBC_2.7)(64bit)
      20. libc.so.6(GLIBC_2.8)(64bit)
      21. libdbus-1.so.3()(64bit)
      22. libdbus-glib-1.so.2()(64bit)
      23. libdl.so.2()(64bit)
      24. libdl.so.2(GLIBC_2.2.5)(64bit)
      25. libgio-2.0.so.0()(64bit)
      26. libglib-2.0.so.0()(64bit)
      27. libgmodule-2.0.so.0()(64bit)
      28. libgobject-2.0.so.0()(64bit)
      29. libgudev-1.0.so.0()(64bit)
      30. libm.so.6()(64bit)
      31. libm.so.6(GLIBC_2.2.5)(64bit)
      32. libmm-glib.so.0()(64bit)
      33. libndp.so.0()(64bit)
      34. libnewt.so.0.52()(64bit)
      35. libnewt.so.0.52(NEWT_0.52)(64bit)
      36. libnewt.so.0.52(NEWT_0.52.13)(64bit)
      37. libnewt.so.0.52(NEWT_0.52.6)(64bit)
      38. libnewt.so.0.52(NEWT_0.52.9)(64bit)
      39. libnl-3.so.200()(64bit)
      40. libnl-3.so.200(libnl_3)(64bit)
      41. libnl-genl-3.so.200()(64bit)
      42. libnl-genl-3.so.200(libnl_3)(64bit)
      43. libnl-route-3.so.200()(64bit)
      44. libnl-route-3.so.200(libnl_3)(64bit)
      45. libnm-wwan.so()(64bit)
      46. libnm.so.0()(64bit)
      47. libnm.so.0(libnm_1_0_0)(64bit)
      48. libnm.so.0(libnm_1_0_4)(64bit)
      49. libnm.so.0(libnm_1_0_6)(64bit)
      50. libnspr4.so()(64bit)
      51. libnss3.so()(64bit)
      52. libnss3.so(NSS_3.2)(64bit)
      53. libnss3.so(NSS_3.3)(64bit)
      54. libpolkit-agent-1.so.0()(64bit)
      55. libpolkit-gobject-1.so.0()(64bit)
      56. libpthread.so.0()(64bit)
      57. libpthread.so.0(GLIBC_2.2.5)(64bit)
      58. libreadline.so.6()(64bit)
      59. libsmime3.so()(64bit)
      60. libsmime3.so(NSS_3.2)(64bit)
      61. libsmime3.so(NSS_3.4)(64bit)
      62. libsoup-2.4.so.1()(64bit)
      63. libsystemd.so.0()(64bit)
      64. libsystemd.so.0(LIBSYSTEMD_209)(64bit)
      65. libuuid.so.1()(64bit)
      66. libuuid.so.1(UUID_1.0)(64bit)
      67. mozilla-nss
      68. ppp = 2.4.7
      69. rpmlib(CompressedFileNames) <= 3.0.4-1
      70. rpmlib(PartialHardlinkSets) <= 4.0.4-1
      71. rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      72. sysconfig >= 0.80.5
      73. systemd
      74. systemd
      75. systemd
      76. systemd
      77. wpa_supplicant >= 0.6.4
      78. rpmlib(PayloadIsLzma) <= 4.4.6-1


      Da ist nix von KDE, GNOME, nicht mal irgendwelche Xorg-Abhängigkeiten.

      Es kann aber sein, dass da irgendein "Recommends" für eines der grafischen Applets gesetzt wurde, dazu sollte man sich /etc/zypp/zypp.conf anschauen, was dort zur Variable "solver.onlyRequires" steht (und die gibt es schon lange, hier in einer 13.1 und wenn sie nicht auf "true" steht, dann werden "recommended" Pakete automatisch nachinstalliert).

      tomfa schrieb:


      kennst du und unter anderem ist dir (nicht nur) nmcli ein Begriff? Ansonsten könntest du dir ja auch mal ModemManager anschauen.


      Prinzipiell richtig, aber seit 13.2 sollte man eher "nmtui" verwenden, sehr viel komfortabler.

      Greetz,

      RM
      "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

      Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

      openSUSE Leap 42.3 - Kernel 5.0.x - fluxbox 1.3.7

      Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K
    1