(Gelöst) - Adobe Flash Plugin lässt sich nicht updaten

    (Gelöst) - Adobe Flash Plugin lässt sich nicht updaten

    Guten Morgen Freunde,

    Ich habe hier seit einigen Tagen ein Update das sich nicht installieren lässt und jedes mal mit einem Fehler beendet wird.

    Es handelt sich um das ADOBE FLASH PLUGIN ( 11.02.202.616-release ).

    Ich würde gerne mehr Infos geben, aber ich weiß nicht so solche Fehler im System hinterlegt werden. Im /var/log/ Verzeichnis habe ich keine Datei gefunden.

    Ich hoffe Ihr könnt mir da " mal wieder " helfen !

    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Wie soll die Aktualisierung denn durchgeführt werden (Update-Applet der verwendeten Arbeitsumgebung, über YaST2 [Online-Aktualisierung oder Software installieren oder löschen], Zypper oder mittels PackageKit und dessen pkcon)?

    In der Konsole als Root/su mal ein

    Quellcode

    1. zypper -vv up

    aufrufen und falls dann noch ein Fehler aufgeführt wird die komplette Ein- und Ausgabe hier vorführen.
    Das geht bei mir über die Akutallisierungsverwaltung in der Statusleiste. Da werden immer alle notwendigen Akutallisierungen angezeigt.

    zypper -vv up brachte folgendes Ergebniss

    l

    Brainfuck-Quellcode

    1. inux-x062:~ # zypper -vv up
    2. Verbosity: 2
    3. Initializing Target
    4. Checking whether to refresh metadata for Externe Programme
    5. Checking whether to refresh metadata for Libdvdcss
    6. Retrieving: http://opensuse-guide.org/repo/openSUSE_Leap_42.1/repodata/repomd.xml ...........................................................................[done]
    7. Checking whether to refresh metadata for adobe-flash-plugin
    8. Retrieving: http://linuxdownload.adobe.com/linux/x86_64/repodata/repomd.xml .................................................................................[done]
    9. Checking whether to refresh metadata for Haupt-Repository (NON-OSS)
    10. Retrieving: http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/content ........................................................................[done]
    11. Retrieving: http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/media.1/media ..................................................................[done]
    12. Checking whether to refresh metadata for Aktualisierungs-Repository (Nicht-Open-Source-Software)
    13. Retrieving: http://download.opensuse.org/update/leap/42.1/non-oss/repodata/repomd.xml .......................................................................[done]
    14. Checking whether to refresh metadata for Haupt-Repository (DEBUG)
    15. Retrieving: http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/content ......................................................................[done]
    16. Retrieving: http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/media.1/media ................................................................[done]
    17. Checking whether to refresh metadata for Haupt-Repository (OSS)
    18. Retrieving: http://download.opensuse.org/distribution/leap/42.1/repo/oss/content ............................................................................[done]
    19. Retrieving: http://download.opensuse.org/distribution/leap/42.1/repo/oss/media.1/media ......................................................................[done]
    20. Checking whether to refresh metadata for Haupt-Repository (Quellen)
    21. Retrieving: http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/content .....................................................................[done]
    22. Retrieving: http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/media.1/media ...............................................................[done]
    23. Checking whether to refresh metadata for Hauptaktualisierungs-Repository
    24. Retrieving: http://download.opensuse.org/update/leap/42.1/oss/repodata/repomd.xml ...........................................................................[done]
    25. Checking whether to refresh metadata for AMD/ATI Graphics Drivers
    26. Retrieving: http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Leap_42.1/repodata/repomd.xml ...................................................................[done]
    27. Checking whether to refresh metadata for google-chrome
    28. Retrieving: http://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/repomd.xml .........................................................................[done]
    29. Checking whether to refresh metadata for Adobe Flash Plugin
    30. Retrieving: http://linuxdownload.adobe.com/linux/x86_64/repodata/repomd.xml .................................................................................[done]
    31. Checking whether to refresh metadata for Opera packages
    32. Retrieving: https://rpm.opera.com/rpm/repodata/repomd.xml ...................................................................................................[done]
    33. Checking whether to refresh metadata for packman
    34. Retrieving: http://mirror.karneval.cz/pub/linux/packman/suse/openSUSE_Leap_42.1/repodata/repomd.xml .........................................................[done]
    35. Checking whether to refresh metadata for openSUSE-Leap-42.1-Source-Non-Oss
    36. Retrieving: http://download.opensuse.org/source/distribution/leap/42.1/repo/non-oss/content .................................................................[done]
    37. Retrieving: http://download.opensuse.org/source/distribution/leap/42.1/repo/non-oss/media.1/media ...........................................................[done]
    38. Loading repository data...
    39. Reading installed packages...
    40. Force resolution: No
    41. The following 2 package updates will NOT be installed:
    42. gstreamer-0_10-plugins-ugly 0.10.19-15.3 x86_64 Haupt-Repository (OSS) openSUSE
    43. gstreamer-0_10-plugins-ugly-lang 0.10.19-15.3 noarch Haupt-Repository (OSS) openSUSE
    44. The following package is going to be upgraded:
    45. flash-plugin 11.2.202.577-release -> 11.2.202.616-release x86_64 adobe-flash-plugin Adobe Systems Inc.
    46. 1 package to upgrade.
    47. Overall download size: 6.9 MiB. Already cached: 0 B. After the operation, additional 1.4 KiB will be used.
    48. Continue? [y/n/? shows all options] (y): y
    49. committing
    50. Retrieving package flash-plugin-11.2.202.616-release.x86_64 (1/1), 6.9 MiB ( 19.5 MiB unpacked)
    51. Retrieving: http://linuxdownload.adobe.com/linux/x86_64/flash-plugin-11.2.202.616-release.x86_64.rpm ..........................................[done (683.8 KiB/s)]
    52. flash-plugin-11.2.202.616-release.x86_64.rpm:
    53. Header V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
    54. Header SHA1 digest: OK (f228f8bfec27bc1dbee7a7e352ff9871fba09d7a)
    55. MD5 digest: OK (55cfa5b37070f6c04e8b540d681e8695)
    56. V3 DSA/SHA1 Signature, key ID f6777c67: NOKEY
    57. flash-plugin-11.2.202.616-release.x86_64 (adobe-flash-plugin): Signature verification failed [4-Signatures public key is not available]
    58. Abort, retry, ignore? [a/r/i] (a):
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    Quellcode

    1. rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-adobe-linux

    hattest du laut Anleitung durchgeführt? Wenn nicht, dann hole es nach und versuche es nochmals mit der Aktualisierung.

    Ansonsten gäbe es noch andere Möglichkeiten oder Alternativen:
    1. i auswählen und den Hinweis ignorieren.
    2. zypper up ohne gpg-check ausführen.
    3. Flash-Player nicht verwenden und deinstallieren.
    4. Flash-Player über das PackMan-Repo installieren und das Repo von Adobe entsorgen.
    5. Flash-Player deinstallieren und dafür freshplayerplugin und chromium-pepper-flash von PackMan installieren.
    6. Google-Chrome verwenden.
    7. Und so weiter.

    Mein Favorit ist/wäre #3.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „tomfa“ ()

    Also mit deinstallierten Adobe Flash funktioniert Opera, Chrome und Chromium. Firefox allerdings geht jetzt nicht mehr.

    Gibt es da nicht auch was für Firefox unter Linux ?
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    OK.. hast recht... ich hatte ein ADDON drin das wohl das blockiert hat.
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Ich hatte ein Adon YOUTUBE FLASH PLAYER installiert.
    Das habe ich gelöscht und auf einmal hat Flash im Firefox wieder funktioniert.

    Jedenfalls funktioniert alles jetzt...

    Vielen Dank ! :D
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „nogaro“ ()

    Bedeutet der Firefox selbst ist gestartet und hat funktioniert, nur Flash-Inhalte wurden nicht angezeigt? Oder Firefox hat den Start komplett verweigert? Und weshalb funktioniert Flash jetzt im Firefox wenn du flash-player deinstalliert hast? Zeige doch mal bitte die Ausgabe von:

    Quellcode

    1. zypper se -si flash fresh pepper
    Ich teste immer mit Youtube.
    Bevor ich Adobe Flash deinstalliert habe ging Firefox mit dem Adobe Flash Plugin.
    Danach nicht mehr als ob es dann Flash blockieren würde. Also habe ich das Plugin gelöscht und jetzt funktioniert es.

    Brainfuck-Quellcode

    1. linux-x062:~ # zypper se -si flash fresh pepper
    2. Loading repository data...
    3. Reading installed packages...
    4. S | Name | Type | Version | Arch | Repository
    5. --+-----------------------+---------+----------------+--------+-------------------
    6. i | chromium-pepper-flash | package | 21.0.0.213-1.1 | x86_64 | Packman Repository
    7. i | chromium-pepper-flash | package | 21.0.0.213-1.1 | x86_64 | packman
    8. i | freshplayerplugin | package | 0.3.4-19.3 | x86_64 | Packman Repository
    9. i | freshplayerplugin | package | 0.3.4-19.3 | x86_64 | packman
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    nogaro schrieb:

    Quellcode

    1. i | chromium-pepper-flash | package | 21.0.0.213-1.1 | x86_64 | Packman Repository
    2. i | chromium-pepper-flash | package | 21.0.0.213-1.1 | x86_64 | packman
    3. i | freshplayerplugin | package | 0.3.4-19.3 | x86_64 | Packman Repository
    4. i | freshplayerplugin | package | 0.3.4-19.3 | x86_64 | packman

    Hat jetzt nichts mit dem Problem zu tun, aber wenn ich obiges sehe, dann hast Du Repos doppelt eingebunden.
    Poste einmal:

    Quellcode

    1. zypper lr -uP

    Brainfuck-Quellcode

    1. linux-x062:~ # zypper lr -uP
    2. # | Alias | Name | Enabled | GPG Check | Refresh | Priority | URI
    3. ---+-----------------------------------+---------------------------------------------------------+---------+-----------+---------+----------+-------------------------------------------------------------------------
    4. 1 | Externe_Programme | Externe Programme | Yes | ( p) Yes | Yes | 99 | dir:///home/nogaro/RPM
    5. 2 | Libdvdcss | Libdvdcss | Yes | (r ) Yes | Yes | 99 | http://opensuse-guide.org/repo/openSUSE_Leap_42.1
    6. 3 | adobe-flash-plugin | adobe-flash-plugin | Yes | ( p) Yes | Yes | 99 | http://linuxdownload.adobe.com/linux/x86_64/
    7. 4 | download.opensuse.org-non-oss | Haupt-Repository (NON-OSS) | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/
    8. 5 | download.opensuse.org-non-oss_1 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/update/leap/42.1/non-oss/
    9. 6 | download.opensuse.org-oss | Haupt-Repository (DEBUG) | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/
    10. 7 | download.opensuse.org-oss_1 | Haupt-Repository (OSS) | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/distribution/leap/42.1/repo/oss/
    11. 8 | download.opensuse.org-oss_2 | Haupt-Repository (Quellen) | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/
    12. 9 | download.opensuse.org-oss_3 | Hauptaktualisierungs-Repository | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/update/leap/42.1/oss
    13. 10 | geeko.ioda.net-amd-fglrx | AMD/ATI Graphics Drivers | Yes | (r ) Yes | Yes | 99 | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_Leap_42.1/
    14. 11 | google-chrome | google-chrome | Yes | (r ) Yes | Yes | 99 | http://dl.google.com/linux/chrome/rpm/stable/x86_64
    15. 12 | http-ftp.uni-erlangen.de-bf2a72f1 | Packman Repository | Yes | (r ) Yes | Yes | 99 | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Leap_42.1
    16. 13 | linuxdownload.adobe.com-linux | Adobe Flash Plugin | Yes | ( p) Yes | Yes | 99 | http://linuxdownload.adobe.com/linux/x86_64/
    17. 14 | openSUSE-42.1-0 | openSUSE-42.1-0 | Yes | (r ) Yes | No | 99 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-STDVD-ROM_GDRH20N
    18. 15 | opera | Opera packages | Yes | (r ) Yes | Yes | 99 | https://rpm.opera.com/rpm
    19. 16 | packman | packman | Yes | (r ) Yes | Yes | 99 | http://mirror.karneval.cz/pub/linux/packman/suse/openSUSE_Leap_42.1/
    20. 17 | repo-debug-non-oss | openSUSE-Leap-42.1-Debug-Non-Oss | No | ---- | Yes | 99 | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/
    21. 18 | repo-debug-update | openSUSE-Leap-42.1-Update-Debug | No | ---- | Yes | 99 | http://download.opensuse.org/debug/update/leap/42.1/oss
    22. 19 | repo-debug-update-non-oss | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No | ---- | Yes | 99 | http://download.opensuse.org/debug/update/leap/42.1/non-oss/
    23. 20 | repo-source | openSUSE-Leap-42.1-Source-Non-Oss | Yes | (r ) Yes | Yes | 99 | http://download.opensuse.org/source/distribution/leap/42.1/repo/non-oss
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Opera und Chrome habe ich extra aufgenommen. Chromium ist nicht ganz das gleiche wie Chrome. Opera nutze ich auch regelmässig. Die Browser sind für mich wichtig.

    Warum PACMAN raus ?? Warum LIBDVDCSS das ich ja für meinen noch nicht funktionierenden Lightscripe-Brenner brauche !
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    zypper rr 3 5 8 13 14 16

    So OK ??
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    nogaro schrieb:

    Opera und Chrome habe ich extra aufgenommen. Chromium ist nicht ganz das gleiche wie Chrome. Opera nutze ich auch regelmässig. Die Browser sind für mich wichtig.

    Wegen Chrome und Chromium: Das ist dir selbst überlassen.
    Opera: Diesen gibt es über das das Non-OSS Repo (was ich immer vergesse).

    nogaro schrieb:

    Warum PACMAN raus ?? Warum LIBDVDCSS das ich ja für meinen noch nicht funktionierenden Lightscripe-Brenner brauche !

    Nur ein Repo von PackMan raus, ist doppelt vorhanden. Von libdvdcss hat niemand was erwähnt.
    Also aktuell würde ich diese nehmen !

    Quellcode

    1. zypper rr 3 5 8 13 14 16


    12 | http-ftp.uni-erlangen.de-bf2a72f1 | Packman Repository | Yes | (r ) Yes | Yes | 99 | ftp.uni-erlangen.de/pub/mirror…n/suse/openSUSE_Leap_42.1

    16 | packman | packman | Yes | (r ) Yes | Yes | 99 | mirror.karneval.cz/pub/linux/p…/suse/openSUSE_Leap_42.1/

    Welches Repro ist besser ?
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Wird der Opera dann trotzdem noch aktualisiert ? Die installations-DVD wird ja eigentlich auch gar nicht mehr benötigt...oder kann es sein das Linux diese mal benötigt. Eigentlich sollte es ja egal sein ob Sie drin steht oder nicht ??

    Ich könnte diese ja auch deaktivieren. Notfalls wieder aktivieren !!
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2