(Gelöst) Virtualbox Fehler - Kernel driver not installed (rc=-1908)

    (Gelöst) Virtualbox Fehler - Kernel driver not installed (rc=-1908)

    Hallo Liebe Open'SUSE Gemeinde,

    Ich habe folgendes Problem. Virtualbox Version 5.2.8 r121009 (Qt5.6.1) von Oracle installiert aber ich glaube das ist ein bekannter Fehler den ich aber selber auch mit suchen nicht lösen konnte. Dazu reichen einfach meine Linux Kenntnisse nicht aus.

    Habe versucht diverse Repros zu aktuallisieren wie hier beschrieben opensuse-forum.de/thread/40000…hr-bzw-die-installierten/

    Aber gebraucht hat es nichts.

    Kann mir jemand helfen ?
    Bilder
    • Auswahl_001.png

      102 kB, 837×418, 88 mal angesehen
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Und zusätzlich noch ein

    Quellcode

    1. uname -r


    hinterher jagen und dessen Ausgabe posten. just in case, falls mehrere Kernel(flavors) installiert sind.

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.18.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K

    Sauerland schrieb:

    Poste:

    Quellcode

    1. zypper se -si virtualbox kernel make gcc

    Quellcode

    1. zypper lr -d


    Brainfuck-Quellcode

    1. zypper se -si virtualbox kernel make gcc
    2. Loading repository data...
    3. Reading installed packages...
    4. S | Name | Type | Version | Arch | Repository
    5. ---+--------------------+---------+----------------------------+--------+--------------------------
    6. i+ | VirtualBox-5.2 | package | 5.2.8_121009_openSUSE132-1 | x86_64 | (System Packages)
    7. i+ | kernel-default | package | 4.4.120-45.1 | x86_64 | openSUSE-Leap-42.3-Update
    8. i+ | kernel-firmware | package | 20170530-17.1 | noarch | openSUSE-Leap-42.3-Update
    9. i+ | libgcc_s1 | package | 7.3.1+r258313-6.1 | x86_64 | openSUSE-Leap-42.3-Update
    10. i+ | libgcc_s1-32bit | package | 7.3.1+r258313-6.1 | x86_64 | openSUSE-Leap-42.3-Update
    11. i+ | libpagemaker-0_0-0 | package | 0.0.3-8.1 | x86_64 | openSUSE-Leap-42.3-Oss
    12. i+ | make | package | 4.0-7.15 | x86_64 | openSUSE-Leap-42.3-Oss



    Brainfuck-Quellcode

    1. zypper lr -d
    2. Repository priorities are without effect. All enabled repositories share the same priority.
    3. # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    4. ---+---------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
    5. 1 | openSUSE-Leap-42.3-0 | openSUSE-Leap-42.3-0 | No | ---- | ---- | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-STDVD-ROM_GDRH20N |
    6. 2 | opensuse-guide.org-repo | Libdvdcss Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/ |
    7. 3 | packman.inode.at-suse | Packman Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/ |
    8. 4 | repo-debug | openSUSE-Leap-42.3-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/ |
    9. 5 | repo-debug-non-oss | openSUSE-Leap-42.3-Debug-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/ |
    10. 6 | repo-debug-update | openSUSE-Leap-42.3-Update-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.3/oss/ |
    11. 7 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.3/non-oss/ |
    12. 8 | repo-non-oss | openSUSE-Leap-42.3-Non-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/ |
    13. 9 | repo-oss | openSUSE-Leap-42.3-Oss | Yes | (r ) Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/leap/42.3/repo/oss/ |
    14. 10 | repo-source | openSUSE-Leap-42.3-Source | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/ |
    15. 11 | repo-source-non-oss | openSUSE-Leap-42.3-Source-Non-Oss | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |
    16. 12 | repo-update | openSUSE-Leap-42.3-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/
    17. 13 | repo-update-non-oss | openSUSE-Leap-42.3-Update-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/ |


    Sind warscheinlich wieder zu viele Repros drin oder Sauerland :)
    Alte Windowsmanie immer mehr als nötig... :D

    Quellcode

    1. uname -r
    2. 4.4.120-45-default


    Mich ärgert das schon das ich das nicht selber hin bekomme. Jetzt weiss ich auch warum Linux keine Viren hat... Das ist selber der grösste Virus ;( Sucht !!
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „nogaro“ ()

    Als root:

    Quellcode

    1. zypper in gcc kernel-default-devel kernel-devel

    Dann kannst du ganz einfach das Virtualbox.rpm noch einmal installieren, am besten mit zypper, denn das installiert auch alle Abhängigkeiten mit. Denn wie du dein Virtualbox installiert hast, hast du uns geflissentlich vorenthalten, ich tippe aber einmal auf:

    Quellcode

    1. rpm -i Virtualbox.rpm


    User auch noch zur Gruppe vboxusers hinzufügen nicht vergessen.
    Und das wars... :/

    Funzt...

    Es kann so einfach sein, wenn man weiss was man tun muss :P
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Noch eine Frage. Wo finde ich die Repro zur Virtalbox damit ich da immer die aktuelle Version zu bekommen und auch diesen GPG Schlüssel importieren. Ich werde aus der Anleitung irgendwie nicht klug.
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Klappt alles. Habe jetzt auf EXT4 umgestellt und meine Einstellungen übernommen sodaß ich kaum noch was machen musste...das ist schon echt klasse bei Linux. So was kenne ich so von Windows absolut nicht.

    Nur ein Problem habe ich mit Virtalbox.

    Quellcode

    1. uname -r
    2. 4.4.76-1-default


    versuche ich dann...

    Quellcode

    1. zypper in gcc kernel-default-devel kernel-devel
    2. Loading repository data...
    3. Reading installed packages...
    4. 'gcc' is already installed.
    5. No update candidate for 'gcc-4.8-11.16.x86_64'. The highest available version is already installed.
    6. 'kernel-devel' is already installed.
    7. No update candidate for 'kernel-devel-4.4.120-45.1.noarch'. The highest available version is already installed.
    8. 'kernel-default-devel' is already installed.
    9. No update candidate for 'kernel-default-devel-4.4.120-45.1.x86_64'. The highest available version is already installed.
    10. Resolving package dependencies...


    Brainfuck-Quellcode

    1. zypper se -si virtualbox kernel make gcc
    2. Loading repository data...
    3. Reading installed packages...
    4. S | Name | Type | Version | Arch | Repository
    5. ---+----------------------+---------+----------------------------+--------+-----------------------------------------
    6. i+ | VirtualBox-5.2 | package | 5.2.8_121009_openSUSE132-1 | x86_64 | VirtualBox for openSUSE 13.2 / Leap 42.1
    7. i+ | gcc | package | 4.8-11.16 | x86_64 | openSUSE-Leap-42.3-Oss
    8. i | gcc48 | package | 4.8.5-24.18 | x86_64 | openSUSE-Leap-42.3-Oss
    9. i+ | kernel-default | package | 4.4.76-1.1 | x86_64 | openSUSE-Leap-42.3-Oss
    10. i+ | kernel-default-devel | package | 4.4.120-45.1 | x86_64 | openSUSE-Leap-42.3-Update
    11. i+ | kernel-devel | package | 4.4.120-45.1 | noarch | openSUSE-Leap-42.3-Update
    12. i | kernel-firmware | package | 20170530-9.1 | noarch | openSUSE-Leap-42.3-Oss
    13. i | kernel-macros | package | 4.4.120-45.1 | noarch | openSUSE-Leap-42.3-Update
    14. i | libgcc_s1 | package | 7.1.1+r248970-1.4 | x86_64 | openSUSE-Leap-42.3-Oss
    15. i | libgcc_s1-32bit | package | 7.1.1+r248970-1.4 | x86_64 | openSUSE-Leap-42.3-Oss
    16. i | libpagemaker-0_0-0 | package | 0.0.3-8.1 | x86_64 | openSUSE-Leap-42.3-Oss
    17. i | make | package | 4.0-7.15 | x86_64 | openSUSE-Leap-42.3-Oss
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Funktioniert... habe mit dem Befehl

    Quellcode

    1. zypper in gcc kernel-default


    den neuen Kernel installiert. So langsam beginne ich diese Befehle an zu blicken.
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    nogaro schrieb:

    Quellcode

    1. i+ | kernel-default | package | 4.4.76-1.1 | x86_64 | openSUSE-Leap-42.3-Oss
    2. i+ | kernel-default-devel | package | 4.4.120-45.1 | x86_64 | openSUSE-Leap-42.3-Update
    3. i+ | kernel-devel | package | 4.4.120-45.1 | noarch | openSUSE-Leap-42.3-Update


    Ein zypper up und danach ein Neustart hätte den kernel-default auch von 4.4.76 auf 4.4.120 gebracht.

    gcc war übrigens lt. deinem vorletzten Beitrag installiert worden und auch vorhanden.
    Siehe zypper se -si xxxxxxxx
    Zusätzlich dazu ist es nicht ganz unwahrscheinlich, daß der Aufruf von "zypper in kernel-default" den neueren Kernel _parallel_ zum alten installiert hat.

    Quellcode

    1. zypper se -si kernel-default


    Sollten dort jetzt der 4.4.76 und der 4.4.120 auftauchen, dann könnte/sollte man noch den alten entfernen (wird ja jetzt nicht mehr gebraucht und dürfte noch keinerlei Schutz gegen Meltdown/Spectre haben).

    Quellcode

    1. zypper rm kernel-default-4.4.76


    Und ja, zumindest mit den grundlegenden Funktionen seines Paketmanagers sollte man sich beschäftigen, ist auch alles andere als kompliziert.

    de.opensuse.org/Zypper

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.18.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K
    Da hast Du recht, da fehlt mir noch einiges. an Wissen.

    Ist das eigentlich der aktuelle Kernel den ich jetzt drauf habe ? Wäre es nicht sinnvoller gleich den aktuellsten Kernel zu installieren ? Wenn ich sehe das Du den 4.15,x installierst hast und ich den 4.4 ?
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2

    nogaro schrieb:


    Ist das eigentlich der aktuelle Kernel den ich jetzt drauf habe ?


    Quellcode

    1. zypper se -s kernel-default


    und die Antwort wird "ja, für openSUSE 42.3 ist 4.4.120-45.1 der zur Zeit aktuellste" lauten (Hint: Was macht "zypper up"?).

    nogaro schrieb:


    Wäre es nicht sinnvoller gleich den aktuellsten Kernel zu installieren ? Wenn ich sehe das Du den 4.15,x installierst hast und ich den 4.4 ?


    In Anbetracht dessen,

    nogaro schrieb:

    Da hast Du recht, da fehlt mir noch einiges. an Wissen.


    eindeutig nein.

    //Nachtrag:

    Um der nächsten Frage "Ja und was ist mit den Sicherheitslücken, die seither im 4.4.x gefunden und erst in späteren Versionen behoben wurden?" vorzubeugen, noch etwas mehr Lesestoff:

    de.wikipedia.org/wiki/Backport

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.18.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K
    Erst mal vielen Dank für die super super Hilfe.
    Durch euch malch Linux inzwischen richtig Spaß jetzt auch wenn mein Kopf zu platzen droht langsam :D

    Jetzt muss ich das Thema nur noch als gelöst makieren. Mal sehen wie das geht !
    Gruß
    Peter

    Rechner :
    AMD Phenom(tm) II X4 945 Prozessor
    AMD/ATI Radeon HD6450
    SSD SANDISD PLUS 480GB ( Linux Platte )
    WDC WD5003ABYX-0 ( Windows 10 Platte )
    WDC WD20EURX-63T
    OpenSUSE Leap 42.3 Kernel 4.4.120-45-default ( 64 Bit )
    KDE Plasma Version 5.8.7 QT Version 5.6.2
    Das Markieren als "Gelöst" geht vielleicht sogar als normaler User (falls man den Thread gestartet hat).
    Das Schließen eines gelösten Threads, damit da nicht irgendwer irgendeinen Beitrag anhängt (der meist mit dem eigentlichen Problem nichts zu tun hat) statt einen eigenen Thread zu eröffnen, ist dann "unser" (=Forenteam) Job.

    Ich erledige das dann mal.

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.18.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K