(Erledigt) SuSE 10 lahmt

    (Erledigt) SuSE 10 lahmt

    Hi,

    als erstes möchte ich sagen das ich sehr positiv vom Suse 10 überrascht bin. War bisher Windowsuser (angewiesen auf Software) und möchte jetzt auf Linux umsteigen. Ich habe mich aus drei Gründen für Linux entschieden.
    1. Kein Spam, Virus, ....
    2. Kostenlos
    3. angeblich schneller als Windows

    Die ersten beiden Punkte wurden Erwartungsgerecht erfüllt, jedoch mit der Geschwindigkeit habe ich noch Probleme.

    Ich habe SuSE auf meinem IBM Thinkpad T30, 1.8GHz, 256 MB Ram installiert.
    Der Start dauert ca. 2 Minuten!!! - das ist einfach zu lange und auch während des Betriebes ist der start von mehreren Programmen oder das umschalten zwischen den Programmen eine langweilige Angelegenheit.
    Die Hardware wurde vollständig erkannt und ich habe auch keine zusätzlichen Treiber installiert, da von IBM keine zusätzlichen zur Verfügung gestellt werden. Auch das Upgrade auf SuperSuSE hat keine merklichen Geschwindigkeitserhöhungen gebracht.

    Vielleicht hat jemand eine Idee wie ich meinem SuSE etwas Beine machen könnte, bin über jeden Tipp dankbar!!!

    cu, nonck

    AW: SuSE 10 lahmt

    hi!
    Als erstes Willkommen im Forum!

    Nun zu deinem "Problem"
    Es ist eindeutig der Arbeitsspaicher. 256MB sind einfach zu Mager für Suse.

    Es gibt noch eine Funktion bei Suse.Die heisst Prelink. Dadurch kannst du Suse "Tunen"
    prelink mittels yast oder apt installieren, prelink über den etc/sysconfig editor aktivieren danach in der Konsole prelink -amR und Fertig.

    Wenn es im etc/sysconfig editor Aktiviert wird dauert es einfach Lange. Nicht erschrecken.
    Er muss ja alle Programme neu Verlinken und das dauert eben.

    Ansonsten versuch mal ne andere WM ausser KDE. Bei so wenig Resourcen würde ich eher Gnome oder ne Andere Probieren.
    Aber Prelink sollte als Erstes gute Dienste Leisten.
    Was du noch Probieren kannst ist Dienste Abschalten die du nicht Brauchst(Aber Vorsicht dabei!!)

    Dies kannst du auch mal Probieren: pc-forum24.de/showthread.php?t=54

    AW: SuSE 10 lahmt

    Herzlichen Glückwunsch zum Schritt! Du wirst ihn sicherlich nicht bereuen..
    Hat der Speed auch etwas damit zu tun, wenn man eine 64Bit Version nimmt, anstatt eine 32bit? Hast Du opensuse.org oder Suse 10 aus der Box?

    Ausserdem dein laptop ist schon etwas älter, und die Programme werden sowieso fetter und fetter. Hol die mal das Iso. zum CD Brennen von DamnSmallLinux (50MB), dann kannst du sehen, was SPEED ist für gewisse Sachen (Bootet auch per Stick!) Weiss aber leider nicht, was für eine Firewall es nutzt? Irgendjemand? (Knoppix Kern)

    AW: SuSE 10 lahmt

    Hi, danke für eure Antworten!!

    1. Ich bin draufgekommen, dass ich tatsächlich die x86_64 Bit Version installiert habe. Werde dies bei Gelegenheit ändern.
    2. Hab jetzt 512 MB Ram drin und es geht gemeinsam mit dem Prelink etwas schneller.
    3. Die Swap-Partition war und ist ok.

    nonck

    AW: SuSE 10 lahmt

    Runlevel5 schrieb:



    Was du noch Probieren kannst ist Dienste Abschalten die du nicht Brauchst(Aber Vorsicht dabei!!)


    Das wollte ich auch mal fragen, wie kann man denn die ganzen Sachen, die am Start gestartet werden abschalten? Also nicht alle, aber manche brauch ich halt nicht

    AW: SuSE 10 lahmt

    Wie Gesagt VORSICHT DABEI!!
    Kannst mehr kaputt machen wie gut.
    Lese erstmal einiges uber System Verwaltung/Administration in den Handbüchern bevor du das machst.

    Ist so wie wenn du im Windows in der Registry fummelst.
    Also ohne Ahnung würde ich da nix Auschalten oder ändern.
    Mache dich lieber erst mit dem System vertraut dann kommst du von alleine darauf was du Abschalten kannst.

    AW: SuSE 10 lahmt

    Da Ding ist, ich hatte vor Suse es mal mit Free-BSD probiert und die Geschwindigkeit davon war einfach unglaublich!
    Das Problem war aber, dass man dafür sicher 2-3 Monate braucht, damit es so läuft wie es laufen muss, damit ich damit arbeiten kann. Soviel Zeit hab ich leider nicht und so hab ich es nach ein paar Wochen wieder runtergeschmissen.
    Ich glaube viel liegt am Kernel. Mein selbstkompilierter Kernel bleibt leider schwarz beim Starten:D
    Wo legt man denn bei Suse die Scripte rein, die am Anfang starten sollen?