(Erledigt) Mysql sehr langsam

    (Erledigt) Mysql sehr langsam

    Hallo ich habe

    2ghz Dualcore
    2gb RAM
    Root Debian Etch
    Auslastung bei ca 0-3%
    Apache,Lighttpd,Mysql,Proftpd

    Alles geht sehr schnell bis auf die Abfragezeiten von der MYSQL db, da dauern kleine Sachen nicht lange aber wenn ich z.b. Gallery2 drauf habe lahmt das wie nichts.

    Auslastung bei gegen 5% aber Page gen. Zeiten von 2sek (auf günstigen nicht gerade schnellen miet Webspace ca 1sek).
    Ich hatte irgendwoher ein "db Test" Script wie viel Zugriffe pro Minute auf die db erfolgen kann und da war mein bezahl space um weiten schneller wie mein Root, was angesichts der Leistung mir nicht erklärlich ist.

    Die db mittels phpMyAdmin anschauen dauert auch recht lange bis sich da etwas aufbaut. Das kenne ich von meinem "Heimserver", der wesentlich schlechtere Hardware hat (Win2k) überhaupt nicht.

    Ich hab erst die Standard mysql.cnf von der Debian Install genommen, nach bisschen suchen eine abgewandelte die aber auch nur minimal Besserung gebracht hat gegenüber der Standard mysql.cnf.


    Weis jemand Besserung ?
    mfg Namero



    [client]
    port = 3306
    socket = /var/run/mysqld/mysqld.sock

    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram

    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket = /var/run/mysqld/mysqld.sock
    nice = 0

    [mysqld]
    #
    # * Basic Settings
    #
    user = mysql
    pid-file = /var/run/mysqld/mysqld.pid
    socket = /var/run/mysqld/mysqld.sock
    port = 3306
    basedir = /usr
    datadir = /var/lib/mysql
    tmpdir = /tmp
    language = /usr/share/mysql/english
    skip-external-locking
    skip-name-resolve

    #
    # Instead of skip-networking you can listen only on
    # localhost which is more compatible and is not less secure.
    #bind-address = 127.0.0.1
    skip-networking

    #
    # * Fine Tuning
    #
    key_buffer = 32M
    max_allowed_packet = 2M
    thread_stack = 128K
    thread_cache_size = 8
    #max_connections = 100
    table_cache = 64

    sort_buffer_size = 512K
    net_buffer_length = 8K
    read_buffer_size = 256K
    read_rnd_buffer_size = 512K
    myisam_sort_buffer_size = 8M


    #thread_concurrency = 10
    #
    # * Query Cache Configuration
    #
    query_cache_limit = 1M
    query_cache_size = 64M
    query_cache_type = 1

    # The following can be used as easy to replay backup logs or for replication.
    # note: if you are setting up a replication slave, see README.Debian about
    # other settings you may need to change.
    #server-id = 1
    #log_bin = /var/log/mysql/mysql-bin.log
    expire_logs_days = 10
    max_binlog_size = 100M
    #binlog_do_db = include_database_name
    #binlog_ignore_db = include_database_name
    #
    # * BerkeleyDB
    #
    # Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
    skip-bdb
    #

    [mysqldump]
    quick
    quote-names
    max_allowed_packet = 16M

    [mysql]
    #no-auto-rehash # faster start of mysql but no tab completition

    [isamchk]
    key_buffer = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M
    !includedir /etc/mysql/conf.d/

    AW: Mysql sehr langsam

    Da unsere Server-Spezies wohl gerade alle in Urlaub sind bzw. keinen Ansatz zum Problem parat haben, wuerde ich es in einem etwas mehr "serverlastigen" Forum probieren, z.B.

    RootForum.de • Die Community rund um Linux/BSD basierte Server

    oder

    Server Support Forum

    (Bitte Querlink auf einen dort eroeffneten Thread posten, dann kann hat man hier auch einen Verweis auf eine eventuelle Loesung).

    Greetz,

    RM
    "Programming today is a race between software engineers striving to build better & bigger idiot-proof programs and the Universe trying to produce bigger & better idiots. So far, the Universe is winning." (Rick Cook)

    Dies ist ein _öffentliches_ Supportforum, keinerlei Support per PN, EMail oder Instant Messenger.

    openSUSE Leap 42.3 - Kernel 4.19.x - fluxbox 1.3.7

    Bitmessage: BM-2D8h8QZmvHfgbixWeiG1NDZHG1iXAhBz8K